Cron Reports only working on 1 Group

Discussion forum about Anuko Time Tracker
Post Reply
ScottishManx
Posts: 7
Joined: Fri Apr 24, 2020 9:05 am

Cron Reports only working on 1 Group

Post by ScottishManx » Thu May 21, 2020 11:46 am

Hello!

We've managed to set up a hourly Windows scheduled task, create a favorite report & schedule it to be e-mailed weekly - all successfully! But it only works in 1 Group, and I have 10 Groups in total.

I'm using an Admin Top Manager profile that seems to have all authority, and it is able to set everything up - but no scheduled reports are produced. I can manually run the favorite report and e-mail successfully.

I've tried renaming reports so that they have unique names & jobs, but still no joy. It feels like there's something not right in the front-end setup & my IT bod can't spot any errors\issues on the scheduled task.

Any thoughts of where else I need to look? :?

Thanks everyone.

peter
Posts: 83
Joined: Sat May 29, 2010 2:06 pm

Re: Cron Reports only working on 1 Group

Post by peter » Thu May 21, 2020 2:42 pm

I would check if the Notifications plugin is enabled in each subgroup.

To test, change cron schedule for each fav report to * * * * * (each minute), then execute cron.php manually in a browser, see how many reports it sends out.

ScottishManx
Posts: 7
Joined: Fri Apr 24, 2020 9:05 am

Re: Cron Reports only working on 1 Group

Post by ScottishManx » Fri May 22, 2020 8:14 am

Thanks Peter,

The notifications plugin is enabled - it needs to be in order to set-up the cron schedule.

Trying to run cron.php in a browser gives me the following error: MDB2 Error: no such field.

Thanks again, Mark.

wrc
Posts: 303
Joined: Tue May 25, 2010 8:30 pm

Re: Cron Reports only working on 1 Group

Post by wrc » Fri May 22, 2020 12:55 pm

ScottishManx wrote:
Fri May 22, 2020 8:14 am
Trying to run cron.php in a browser gives me the following error: MDB2 Error: no such field.
Your database schema is out of sync with the code you are running. Possibly because of incorrectly performed update.

ScottishManx
Posts: 7
Joined: Fri Apr 24, 2020 9:05 am

Re: Cron Reports only working on 1 Group

Post by ScottishManx » Fri May 22, 2020 3:05 pm

Thanks wrc - we've some group changes this weekend, so I'll see where we are next week, and re can look to reinstall.

The 1 report that is working has a custom field that the other groups don't have, so I'm wondering if that has an impact. The changes this weekend will give the other groups that custom field, so the issue may go away.

Post Reply