PHP version compatability

Discussion forum about Anuko Time Tracker
Post Reply
dalescott
Posts: 54
Joined: Fri Apr 21, 2017 2:53 pm
Location: Calgary, Alberta, Canada
Contact:

PHP version compatability

Post by dalescott » Wed Oct 18, 2017 3:32 pm

Hi, is TimeTracker fully compatible with PHP7? I'm still using PHP 5.6, but will eventually want to upgrade to v7.

Also, /README.txt says the PHP MySQL module is required, is this literally correct? I.e. mysql, not either mysqli or mysqlnd. Also, is there any desired eventual change on the roadmap? (just curious)

Thanks,
Dale

Nik
Posts: 419
Joined: Wed May 26, 2010 5:55 pm

Re: PHP version compatability

Post by Nik » Fri Oct 20, 2017 3:38 pm

PHP 5.6 as well as PHP 7 should be fine. If something is broken please let us know.

I fixed readme.txt to remove mysql extension references, as now you can use mysqli as well as mysql. Install mysql extension only if you use it (in the $dsn in config.php).

As for the roadmap: which roadmap? It's difficult to do realistic long-term planning.

dalescott
Posts: 54
Joined: Fri Apr 21, 2017 2:53 pm
Location: Calgary, Alberta, Canada
Contact:

Re: PHP version compatability

Post by dalescott » Wed Oct 25, 2017 5:05 pm

Thanks Nik for clarifying PHP version and mysqli compatibility.

I understand difficulty of long-term planning, but what about your project "vision"? Assuming it _was_ possible to do realistic planning, what features would you like to see that address your need, or seem to come up in the forum more often than just once?

I see you as the first customer for TimeTracker, not only the longest term developer, so I think you probably have some pretty good ideas. ;-)

Cheers,
Dale

ITW
Posts: 2
Joined: Tue Oct 31, 2017 8:46 pm
Location: Austria/Europe

Re: PHP version compatability

Post by ITW » Tue Oct 31, 2017 8:48 pm

I use it with 7.1.11 without problems (at the moment).

Post Reply