Blank Page Problem

Discussion forum about Anuko Time Tracker
Post Reply
uzbonn_mo
Posts: 3
Joined: Mon Jan 11, 2021 4:56 pm

Blank Page Problem

Post by uzbonn_mo » Mon Jan 11, 2021 6:16 pm

Hi there!

I wanted to upgrade my current Timetracker version to the newest one but wasn't able to do so.

But let's start from the beginning:

So I started with following the instructions given at https://www.anuko.com/time_tracker/inst ... pgrade.htm.
Since I have an old version running, I backed up the code and the db, replaced my old code with the new one, set up full access rights to the folder "WEB-INF" and modified the config.php file. After that I went on to update my database.

Unfortunately it didn't go as planed. I got a bunch of errors while updating the database (current version is 1.19.4) to version 1.19.23. I wanted to try to log in anyway so I headed to the login.php but all I could see was a blank page. I checked the readme.txt but everything written in there was already done before.
So I copied back my old but working code, put in my information but got denied access. After rolling back my database everything went back to where it was.

After that, I created a new database and linked it to the new timetracker version (old and new are both running now). Now dbinstall.php isn't giving me any errors and I got the newest database version running (according to dbinstall.php) but still a blank page when I try to access the login page.

Since I'm not the one who configured the old version I'm pretty lost at the moment.
I checked the Apache logfiles but didn't see any errors. Are there any other logfiles I should check?

I tried chaning the max_execution_time to 3600 and deleted dbinstall.php and did a lot of stuff that I found while doing a google search but nothing is working, thats why I hope to get some help here.

I'm new to this, so there might be some things considered trivial wich might not be trivial for me so please be pacient.

Thanks in advance.
Sincerely yours,

Mo

wrc
Posts: 312
Joined: Tue May 25, 2010 8:30 pm

Re: Blank Page Problem

Post by wrc » Tue Jan 12, 2021 2:48 am

uzbonn_mo wrote:
Mon Jan 11, 2021 6:16 pm
set up full access rights to the folder "WEB-INF"
The above is wrong. Instead, you shoud have done it on WEB-INF/templates_c/ folder.

uzbonn_mo
Posts: 3
Joined: Mon Jan 11, 2021 4:56 pm

Re: Blank Page Problem

Post by uzbonn_mo » Tue Jan 12, 2021 11:20 am

Hi wrc, thanks for the response.
I did it to the templates_c folder first but when that didn't work out I tried to apply it to the WEB-INF folder as well.
The dbinstall.php is telling me that templates_c is writeable so I think it makes no big difference, does it?

Thanks in advance!

peter
Posts: 88
Joined: Sat May 29, 2010 2:06 pm

Re: Blank Page Problem

Post by peter » Tue Jan 12, 2021 3:37 pm

uzbonn_mo wrote:
Mon Jan 11, 2021 6:16 pm
I checked the Apache logfiles but didn't see any errors. Are there any other logfiles I should check?
Apache has access log and an error log, which are different files configurable per application. You need to find out what ther error log file is and examine it when youi try to access the login page. Access file does not have any errors.

peter
Posts: 88
Joined: Sat May 29, 2010 2:06 pm

Re: Blank Page Problem

Post by peter » Tue Jan 12, 2021 4:21 pm

Another thing to try is to enable displaying errors on screen on line #13 in initialize.php. Set it to On temporarily.

Code: Select all

// Enable displaying errors on screen.
ini_set('display_errors', '1');

uzbonn_mo
Posts: 3
Joined: Mon Jan 11, 2021 4:56 pm

Re: Blank Page Problem

Post by uzbonn_mo » Wed Jan 13, 2021 12:53 pm

peter wrote:
Tue Jan 12, 2021 4:21 pm
Another thing to try is to enable displaying errors on screen on line #13 in initialize.php. Set it to On temporarily.

Code: Select all

// Enable displaying errors on screen.
ini_set('display_errors', '1');
Thank you so so much!! I was able to trace the error back and now I got access to the login page.
For anybody with the same problem, I had a file missing named "index2.tpl".

Thanks again to you two!

Post Reply